apostrophe's in title searches

KeskusteluRecommend Site Improvements

Liity LibraryThingin jäseneksi, niin voit kirjoittaa viestin.

apostrophe's in title searches

maaliskuu 10, 10:31 am

When looking for a record to add a book, the search will not work if an apostrophe is in the title. Please make it possible to search for a title that includes an apostrophe.

Muokkaaja: maaliskuu 10, 10:50 am

I just searched for L' ABC de la foi on the add books page using the source SUDOC, and got several results including the one I wanted.

Asimov's guide to the Bible searched on the add books page in Overcat came up with 22 results.

As the touchstones worked, it is clear that site search accepts apostrophes.

What title were you searching for? Which search were you using, and which source? If there is a problem, this information is needed to hunt it down.

Also, if there really is a problem somewhere, Bug Collectors would be a better group for reporting it. https://www.librarything.com/ngroups/897/Bug-Collectors

maaliskuu 10, 10:53 am

>1 yedlint: Unfortunately I wasn't able to reproduce what you saw there.

As >2 MarthaJeanne: says can you give us more details and we'll try to replicate and fix?

maaliskuu 10, 12:09 pm

Is this anything to do with Unicode and "smart" apostrophes? LT used to discriminate between them, and searching for one form of apostrophe in CK would not find the other. This issue has recently been resolved (https://www.librarything.com/topic/327429).

If you are repeating a previous search that had worked before this tweek, perhaps it is worth refreshing it to make sure you are not using cached versions.

maaliskuu 10, 12:15 pm

I just spent some time hunting down the difference between

Bandes dessinées


Bandes dessinées

but that wasn't LT's fault :-)

The é is quite irritating since it is an e with a trailing apostroph.